Updated from V3.0 to 3.1 and now Racast2D won't collide with Area2D

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Arkinum

I just converted a project I was working on and now my Raycast2d setup is not colliding with my Area2D’s. I’m just using a simple .is_colliding. It can see my static bodies just fine.

:bust_in_silhouette: Reply From: Arkinum

OK I feel stupid now.

Seems there is a new parameter in the Raycast2D node that lets you enable/disable Area and Rigidbody collisions. Just below the collision mask -_-