V4.2.1 crashes when opening any project - vulkan incompatibility?

Hello, all. I am new to Godot and eager to dive into tutorials, but I’ve run into an obstacle before I even had a chance to start. I apologize for the dumb question, as this is likely just a system compatibility problem. When I launch Godot 4.2.1, it opens and behaves normally until I try to open a project, at which point it simply closes. When running the console version of the executable, the console window closes along with the main one before showing any output. I have attempted to create and open new projects, and to open example projects downloaded from the asset library with the same result.

I ran the engine from the command prompt instead, so I could find out what was happening, and here it is:

I should mention that I am a composer and recording engineer, and computer savvy mainly within that realm. The computer on which I’m trying to run Godot is running Windows 7 64-bit, has a fast 8-core processor and 32GB RAM. The video card is obviously nothing special, because I don’t need much in the way of graphics processing for a music workstation. I’m not knowledgeable about GPU hardware and such; I’m not a big gamer these days. I had some experience making games in another engine about 20 years ago, and decided it would be fun to do something like that again (if only so I have something that gives me an excuse to compose a score, heh).

Is this a simple hardware incompatibility? Or a firmware/driver issue, maybe? I should also mention that the computer in question is not and will not be connected to the internet, so automatic updates are not part of its life. Am I better off running Godot on a different machine? I only intend to make 2D games (hoping to take a crack at a 90s-style 2D isometric RPG/adventure type game).

Thanks so much for reading. :slight_smile:

Looking at Nvidia website the gtx 650 does not support Vulcan 1.3. I actually didn’t see it on the list so I don’t know where it stands. Without upgrading your hardware the only thing you can do is run in compatibility renderer mode. a.k.a. opengl3.

If you can’t open the editor there is a command line option to choose the editor renderer. (Can’t remember if this can be saved somewhere so you don’t have to use the command line each time… Maybe make a special shortcut with the option embedded)

When making a new project you can select the renderer.

If you have an existing project, go to the project settings and change the renderer to compatible under the rendering options category.

Thanks for the reply! Creating a new project with the renderer in compatibility mode seems to solve the problem.

I don’t have any existing projects to worry about, but example projects from the asset library are still going to be a problem because I don’t see an option to change the renderer when importing them. You said there was a console command to force Godot to run in compatibility mode. I’m assuming it’s either --rendering-method <renderer> or --rendering-driver <driver>, but I’m not sure of the usage syntax here. Do I need to be in the directory for the project, or the one containing the Godot executable?

Again, thanks for your help! I’m going to start digging in.