VideoPlayer After Export

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Michael Marid

Greetings! I’m dealing with the following problem:
I am able to use a videoplayer node in my project (Godot3-Stable) and I can see the .ogv file when I am hitting the play button. But when I export my project (on android, windows or html) I get (on console) the error:
“ERROR: VideoStreamPlaybackTheora::set_file: Condition ’ !file ’ is true.”
As a result the video is not shown (every other node is showing on the screen).
I would appreciate any help.

Now checked, I too don’t start video after export. I don’t think it’s here. Looks like github should be writing a bug report.

DimitriyPS | 2018-02-12 13:49

:bust_in_silhouette: Reply From: enzopoeta

Hi ! You may need to put the ogv extension in the non resource filters on the project export options so the video file will be wrapped with the rest of the application. Just a guess ! =)

Have tried that and it didn’t work.

DimitriyPS | 2018-02-13 07:00

I’m having the same problem …
What other file formats could I use instead of ogv? Is that the problem?

masg | 2018-02-14 01:32

:bust_in_silhouette: Reply From: Michael Marid

The only solution I can think of is the following:

  1. Load Video from “user://” (it will not show on editor)
  2. Make the apk and install it on android device
  3. Create a folder on Android/App (ex. org.godotengine.videoapp) and put the video.ogv

I have tried it without any luck. If anyone can somehow relate it I would really appreciate it.

:bust_in_silhouette: Reply From: DimitriyPS

Just all waiting for the fix.

:bust_in_silhouette: Reply From: Maxpilot

For Windows: Just put the .ogv file(s) in the export directory, at the same place where they are like in the project directory.