VR on mobile device has low performance!

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Olaf007

Hi, recently I created a simple 3D-Scene in GLES2 with the default environment and no others nodes than the root-Spatial, ARVROrigin + Camera and a PlaneMeshInstance. I implemented the “Native mobile”-VR-Server-Script and exported the project to Android so I can see how it runs.
BUT: The game - without any objects - achieves barely 23 FPS.
My phone is not the newest but I can play multiple Google-Cardboard-Games fluently. And on the other hand, an empty Godot-Scene can not make more then 23 FPS. Is there any setting that tramandously increases the framerate?
In fact, at least 30 FPS should be a minimum for any VR-experience!

is vsync turned on? and what resolution are you running at? try to adjust both.

Jason Swearingen | 2020-02-04 12:51

Yes, VSync was on but it did not changed anything on my mobile device: still 23 FPS whereas my laptop runs it with over 600 FPS without VSync now. How can I change the resolution? Changing width and heigth does not seem to effect the resolution on smartphones and I cannot pack the scene into a viewport because then VR is not rendered anymore.
Thank you. :slight_smile:

Olaf007 | 2020-02-04 17:21

The Godot devs said that it’s relatively beta and then theirs the fact that its vr so it might be your phone.

Merlin1846 | 2020-02-08 04:30

:bust_in_silhouette: Reply From: age_apache


Please could you point me to some tutorial on how to enable XR app development for Android mobile phones using Godot? What are the steps required to enable XR apps for Android mobile phones using Godot?