VSCodium instead of VS Code

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By cbec


I am testing the mono version of godot. I have VSCodium installed on my system (w10), which I use for other projects, but I haven’t been able to get godot to recognize it for me.
I don’t know if there is any manual way to tell it to use another editor, since it only looks for VS code.

Greetings and sorry for my English, I used google translate

:bust_in_silhouette: Reply From: juppi


You have to set up an external Editor in Godot, because Godot is just looking for the Microsoft Visual Studio Code by default:

But I’m not sure, if VSCodium fully supports C# with debugging, because the Omnisharp Language Server is under proprietary license:


By doing it that way it also becomes the editor for gdscripts and I didn’t want that, a similar option is missing for mono only.

So far I haven’t had any problems with VSCodium, it’s my first mono project.

Greetings and, again, sorry for my English :slight_smile:

cbec | 2022-05-07 19:47

You also need to go to Editor Settings > Mono > Editor and set that one to disabled.
After that, Godot should use the same Editor for GDScript and CSharp.

juppi | 2022-05-08 09:47