When I open Godot, it automatically executes a project

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By casasvoley07
:warning: Old Version Published before Godot 3 was released.

I downloaded the program a few weeks ago. When I opened it, everything was right. I created a little program to test the engine. Now, when I open Godot, the program I created is executed, but the engine’s interface isn’t, so I can’t make any other programs.

Can anyone help me?

:bust_in_silhouette: Reply From: vnen

If the executable find an engine.cfg file in the current folder, it’ll try to run that project. So you need to move the executable out of the project folder to run the editor (or run the program with specific flags).

Haha, nice one :smiley:

Zylann | 2016-07-13 19:55

For the reference, the -pm flag will force opening the project manager even if there’s an engine.cfg, data.zip or data.pck in the binary’s folder.

Akien | 2016-07-14 06:08

Note that engine.cfg has been renamed to project.godot in Godot 3.0 and later. This issue still applies otherwise.

Calinou | 2021-05-05 18:27