When my project is in fullscreen mode, all the pixels from the sprites are not pixel perfect

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By boy

I’m having a trouble with fullscreen and my pixel art sprites. I have tryed some scripts and change to different resolutions (320*180 the one im using now), but the result its all the same: some pixels slightly higher than others, making it not pixel perfect

:bust_in_silhouette: Reply From: exuin

If you want your pixels to remain the same size, then you need to scale your game by a whole number factor. I’m guessing that the resolution of your monitor when at full screen isn’t a multiple of the resolution of your game. I wouldn’t worry to much about this though.

A solution for this would be to use a viewport and control its scaling yourself.

I really have no clue about this stuff, but gonna try to understand it better. Btw my monitor have 14 inches wide (1600900 I guess/16:9) so what resolution would you recomend for this project? I set the width and height to 640360, using stretch mode 2d and aspect keep. That try give me the same result, so I set it up to mode viewport and aspect ignore, it seems to be kinda better but still get some pixels wrong.

boy | 2021-03-13 05:11

That’s weird. 320*180 is also 16:9. Not sure what’s wrong there.

exuin | 2021-03-13 05:51

Ok then. Thank you for the feedback, Im gonna try some other resoutions and see if fits better or not in 16:9 or other aspect ratios.

boy | 2021-03-13 16:11

:bust_in_silhouette: Reply From: Peachykm

If you go to project settings and then down to display and then window and go all the way down to stretch. There should be an aspect setting and you can change it to keep. This will make the ration always the same and if people monitors are different then it will set them to have black boarders.

so if I set it to have the same size in all monitors, maybe it would be all right for the most of them?

boy | 2021-03-15 16:36