Where is the use_fragment_lighting setting for Android in Godot 3.0.*?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By paco

I wrote a custom shader (and even simplified it to just setting albedo), but it wasn’t showing up in adroid, but fine in windows. I found this post:


Which referred to “Scene > Project Settings > Rasterizer.android” and enabling use_fragment_lighting. Things have been moved around but I can’t find that setting anywhere and I’m betting it’s what I need since the other things in my scene using the default shader show up fine.

FWIW, I’ve been using Godot 3.0.2 but checked 3.0.6 and still can’t find it.

Also cannot find it… did you manage?

bashan | 2020-03-02 22:09

Please I go crazy NOT finding this. Eventually, I have figured out, we need to change environment texture size to pass the android and ios. But this is not a solution for a long time

Okan Ozdemir | 2020-03-29 11:08

any of you find any solution for this yet?

zen3001 | 2021-01-28 13:56