Why am I getting a black screen on this basic godot4 3d scene?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By BusterDublup

i just have a world environment, directional light, and camera 3d all set to the defaults but all i get is a black screen. it works in godot3 but not godot4 and I don’t know why. Please help. Thanks.

![screen cap of the whole project]

Most likely to do with the sky as this is in the editor so the camera would have no affect on it whatsoever.

It could likely be a be the energy slider but I doubt it. Bad environment resource or are you using the inbuilt ones?

LordBoots | 2022-12-03 15:01

I read up on this a little bit. you may have to set it as a child of the camera in godot 4

LordBoots | 2022-12-03 15:04

are you able to link me to the environment resources you’re using? I’m going to try and replicate this issue then fix it for you. cheers

LordBoots | 2022-12-03 15:07

thanks for the reply. i just used the default world environment generated by the “edit sun and environment settings” three dot menu towards the center top of the screen in the screen shot

BusterDublup | 2022-12-03 15:15

:bust_in_silhouette: Reply From: LordBoots

I think I know what’s going on here.
Under 'View" can you check to see if “Show grid” and “Show origin” is turned on please.
This is the only way I could replicate this issue, are your objects currently in view of the Viewport in the black screen image?

I don’t know why these would be turned off by default unless there’s a hotkey for it that’s accidentally been turned on.

If this isn’t what’s going could you let me know, then I’ll need a couple more hours to work through this.

I double checked, “view origin” and “view grid” under the “view” menu next to transform are both turned on so don’t think that’s it.

BusterDublup | 2022-12-03 15:32

Very strange. I’ll open your version of Godot and see what’s up there.

Are you able to start a new project and see if it happens again?

LordBoots | 2022-12-03 15:35

Appears to be a bug!

I could replicate it in Beta-6 but not in Beta-7

LordBoots | 2022-12-03 15:39

sure. i just tried creating a new project with the default world environment, camera 3d, and directional light and i get the same issue. all i can see is a black screen in the editor and when running the project.

BusterDublup | 2022-12-03 15:41

i just downloaded beta 7 and in a new project with the same setup from the screen shot i still only get a black screen

BusterDublup | 2022-12-03 15:50

Very strange, I’ll keep digging through this. Do you have any custom resources running?

LordBoots | 2022-12-03 16:11

no, nothing. just the default three nodes in the screen shot.

BusterDublup | 2022-12-03 16:14

What is your fog color set to if it’s on at all. is this your first time using godot 4?
I’m wondering if it’s an issue with your graphics card and the vulkan renderer

LordBoots | 2022-12-03 16:15

the fog setting on the world environment is not enabled.
i have used godot 4 for 2d stuff here and there with no problems but this is the first time i have tried 3d so maybe there could be some vulkan or graphics card thing. i don’t know.
I’m on an older computer with a GTX 1060

BusterDublup | 2022-12-03 16:22

I often run into these issues too as I run an older PC with an Rx480 installed.

Maybe a driver refresh/reinstall may cure this issue.

Fairly certain a 1060 is plenty powerful enough and new enough that you shouldn’t have issues. I could be wrong though as it was a less popular card when it came out.

LordBoots | 2022-12-03 16:28

I think you’re right, it might be a graphics card/vulkan thing. i just tried the same project on a newer computer and it works fine on that computer.
is there some place i can report an issue like this so that they know there might be a problem with gtx 1060s?

BusterDublup | 2022-12-03 16:37

That’s a bummer that you can’t use that PC to do it.

I would try doing a fresh install of drivers using DDU before you submit a post just to be sure we aren’t wasting the devs time with non-issues.

If that doesn’t work then I’m sure you can google how to submit a bug report, I haven’t had to do it myself yet I’m sorry so I can’t help in that department.

LordBoots | 2022-12-03 17:08

OK. I really appreciate you taking the time to try and help me. thanks anyway.

BusterDublup | 2022-12-03 17:23

Hello I am also having the exact same problem as you, I am using Godot v4.2.1 I have tried several things and I am successful.My first step was to add godot to the environmental variable in the variable path, located in “advance system settings”

(control panel > system security > system > advance system settings > environmental variables > click path > then “edit” > click browse… > “search for problematic Godot applications”)

then save. I also experienced that when opening a godot file with render forward+, I experienced a “force close”. And I tried a way to fix it by creating a “.bat” file.

(In the “godot folder” > add text from notepad > type “object name” the problematic godot application [where click the problematic godot application then click security properties there is an object name Then copy it] after that > into the notepad that was made earlier Paste the copy of the object name > then put a sign (") at the beginning of the sentence until the end > after that put 1 space and Type --rendering-driver opengl3 > then save with the file name “openGodotlnOpenGL3.bat” > if the file name ends in .txt change it to .bat by renaming it > then save and run)

From the bat file that was created earlier. That’s all I did for this problem, if I can’t, I’m sorry, I can only help a little in this way.

Thanks ฅ⁠^⁠•⁠ﻌ⁠•⁠^⁠ฅ