Why am I not seeing files in FileSystem tab?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Freedan

With any project I create, I can no longer view files in the FileSystem tab. Even with new projects, I cannot see default_env.tres or Icon.png within the FileSystem tab. I can drag and drop files to the FileSystem tab, and they appear to import (I can see them when I "Open in File Manager), but not in the tab. I’ve also noticed that in the Orphan Resource Explorer, all of my files are listed as Resources Without Explicit Ownership. I’ve just started development and I don’t think I’ve changed any project settings related to this.

EDIT: I noticed that if I toggle “Split Mode” my resource files become viewable in the new window that pops up. However, the FileSystem tree view still doesn’t show anything but folders.

:bust_in_silhouette: Reply From: deaton64


Maybe there’s a setting that’s got screwed…but I can’t see which one would do that.
Have you changed the editor theme?

Editor settings are saved (on my computer at least) in C:\Users\username\AppData\Roaming\Godot\editor_settings-3.tres

You can rename that file and launch Godot and see if the files come back. A new .tres file will be created, so you can quit Godot, delete that and rename the old file back to get your original settings.

If I turn on “show hidden files” in the editor, this is the line that gets saved in the file settings file:

filesystem/file_dialog/show_hidden_files = true

The edit settings file can be edited using a text editor.

Maybe upload your file and I’ll try it on mine to see if I get the same thing.

That was precisely what I needed! Recreating the .tres file also fixed an issue I was having where the TileSet editor would not appear. When comparing the two profiles nothing stands out as obvious, the old file has a few extra lines of “text_editor” settings, and the “projects/…” line was in a different spot. In any event, problem solved, and will keep in mind if I encounter IDE wonkiness in the future. Thanks!

Freedan | 2021-10-13 22:55

for people encountering this issue in the future;
I had the remove the setting _default_feature_profile from editor_settings-3.tres for files to show up again.

Serenity | 2022-01-28 23:01

What do you mean when you say, “remove the setting _default_feature_profile from editor_settings-3.tres”? I believe I have found the editor_settings-3.tres, from clicking ‘open editor data/settings folder’ . But what do i do from there?

I too am having issues with a folder not showing up in the filessystem tab. Its just one folder

MG | 2022-04-07 00:24

do a search (ctrl + f) for _default_feature_profile.
then remove the line.
meanwhile Godot should be closed.

you aren’t using the Godot 4 alpha 6 though, right? if you are, then you are likely encountering an entirely different issue where folders containing a project.godot are invisible. more about that here.

Serenity | 2022-04-07 17:00