Why can I not use a child of an instanced node to assign to a variable of another child of an instanced node?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By navett52

I have two nodes, powers which can power an object, and powerable which is something that can be powered. I have created nodes that have these power-type nodes as children. pressure_plate which is able to power powerable objects and door which is something that is able to be powered.

A powerable needs to know what things may power it, so it has an exported array that accepts powers nodes. I have put the pressure plate and door in the same scene, and need to assign the powers node of the pressure plate to the powerable node of the door, but I seemingly cannot do this. I have tried setting editable children on both nodes, doesn’t work. I have tried making both instances local, which also doesn’t work.

Attached is a screenshot that shows the editable children scenario and it looks like I should be able to select the NanoPowers2D node (my powers node), but when I double click it I get no errors, it looks like it should work, but the element of the array stays empty.

link to image

:bust_in_silhouette: Reply From: navett52

It is apparently a known issue in 4.0 and even 4.0.1. It looks like it is slated to be fixed in 4.1. A little annoying, but Juan is being careful to avoid potential corruption of engine generated files. I do have some ideas for some potential workarounds, I will update this answer if I find any that work.