Why do my 3D imports from Crocotile3D to Godot look blurry?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By lonertango

I made a 3D model on Crocotile3D, and it looks fine there and when imported to Blender.

However, when I import it to Godot Engine the textures look blurry and really weird and ugly. I’ve tried deactivating the filter (and that actually works) but, for some reason, it won’t let me SAVE the changes to the textures. Can someone help me out? I want my 3D model to look crisp and sharp like in Crocotile3D or Blender. Thank you.

What file formats (e.g. *.obj, *.gltf) have you exported from Crocotile3D and have tried importing into the engine?

Ertain | 2021-02-28 06:54

it was a GLB. file!

lonertango | 2021-02-28 22:17

Have you tried exporting the model to another file format? (Can that even be done with Crocodile3D?)

Ertain | 2021-03-01 04:18

Yes, I have, but I’ve been told that the best exporting format is .GLB

lonertango | 2021-03-02 22:10

:bust_in_silhouette: Reply From: BodaMat

Mmm… It’s really interesting. I know for this situation need to use the filter 2d Pixel for all textures in the import tab. To make the 3d scene see these textures you can also try to tick Detect 3D option.
When you change the texture filter it doesn’t save to texture it saves to the .import file. So it applies only to Godot. Maybe I don’t understand something.