Why do spotlights cause 'shadow acne' no matter what?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By 703337

This has been happening with spotlights since about 3.2.2 and still occurs in 3.4.4 but only if a surface is not facing directly towards the spotlight:
Spotlight Shading Issue

Have you found any fixes yet? I’m still having this issue with Spotlights. I’ve enabled the “Reverse Cull Face” option but problem is occuring

aZaamBie | 2022-07-24 21:51

:bust_in_silhouette: Reply From: Calinou

This is a known issue in 3.x: SpotLights with shadows enabled cause artifacts to appear in the editor (`3.x` only) · Issue #12028 · godotengine/godot · GitHub

Until Godot 4.0 is released, see the recommendations outlined in this section of the 3D lights and shadows documentation, or disable SpotLight shadows.