Why do Webm Videos stop working above 30FPS on Linux(Ubuntu)?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By mrwappa


  • AMD Ryzen 3 3200G
  • GTX 1050
  • Ubuntu 20.04 LTS
  • Godot 3.2.1 Stable

On Windows 10, I’m able to run Webm videos that have an FPS of 60, no problem. On Ubuntu however, the video freezes on the first couple frames or is completely black.

The reason I suspect this is an FPS problem is because EVERY Webm video that is 30FPS or below works on Ubuntu, but none that are above 30FPS do. I’ve tried to convert the videos with different encoders(VP8,VP9), Bitrate, Constant/Variable framerate etc. but it all comes back to the FPS.

So then I tried using the OGV (Theora) format. It seems to work on Ubuntu at 60FPS, BUT…there’s a bar at the bottom of the video that’s looking like some bad quality artifact. This happens on both Windows and Ubuntu.

I suppose you would ask: “Does any of this occur on a regular video player?”. No, it does not. These problems only occur in Godot. None of these problems occur on Ubuntu or Windows when using the standard Video Player provided for those Operating Systems.

I’m using the VideoPlayer Object in Godot to play the Videos.

Any idea why this is happening?

WebM is difficult to support well, which is why support may be moved to a GDNative plugin in the future. See Issues · godotengine/godot · GitHub

Specifically, this issue.

Calinou | 2020-05-23 13:19

Damn, well thanks anyways.
When you mention a GDNative plugin, do you mean something like this?

mrwappa | 2020-05-23 13:57