Why does Godot add extra tracks to my animations from blender as a .glb?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Mr. Gamezz

Dear people, for some odd reason, when I import my .glb file from blender, Godot adds extra tracks to every animation. For example, In blender, I have an animation that only effects the arms of the character(only has keyframes from the arms), but in Godot, it also adds the tracks for the legs, setting them back to their default pose, which is not what I want. Does anyone know how I could fix this?