Why does setting the "monitorable" property to false make monitoring stop working in the same Area2D?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By drakonic

So I have this Area2D node called “CoinDetector”, and when a coin (StaticBody2D) enters it, it emits the “body entered” signal.
Everything works properly until I set the “monitorable” value in “CoinDetector” to false… Why is this? I really want monitorable turned off, because otherwise it would disrupt some other Area2Ds.
Side note, I’ve tried messing around physics layers and masks, but it seems no matter what an Area2D will always detect another Area2D, no matter the masks and layers they have. Why?

:bust_in_silhouette: Reply From: Ertain

Turning off “monitorable” for an Area2D stops it from, well, monitoring other areas that go through it. Area2D nodes in the same collision layer and mask will detect each other. If an Area2D node is in layer 1 (and only layer 1), it will not be able to detect another Area2D node who’s in layer 2.