Why Does the "Play the Project" Window Open Instead of the Interface Itself?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Euergetes

Everything was fine until tonight. I have been going almost without a break for days trying work my way through my project, the code, etc. It is a nightmare trying to learn this stuff but I am making progress with it even if it is very slow.

Tonight I ran the game in the editor (the “play the project” function) and closed the editor with that still running in the background.

A few minutes later I went to open the editor. The small black box that logs the functions and errors came up as usual but instead of the interface, my project itself, in the play the project window came up instead. For over an hour I tried to resolve this issue until I figured out moving the engine.cfg out of the directory (or renaming it) allows the interface to open normally but of course - no project! I figured out that, before doing anything in the Project Manager, return the config file back to where it belongs. Then, scan for my project, after which it finally opens the interface with the project intact and working. I thought it was now fixed but I tested it to be sure and it still opens into the game window instead.

I have no idea what happened here, but to open the engine, I have to perform the above steps to get in and be able to continue with the project.

Apparently the engine.cfg file got corrupted. There isn’t much to it and I will post the contents of the file here. If anyone can help me with this issue, it would be greatly appreciated! Is there anything missing in the following…?


name="Godot 2.1.4"









If what’s here is normal then I’m assuming the editor program itself somehow got corrupted.

…and yes, I know this is 2.1.4 There’s is much more help online to work in this version than in 3.1. My biggest problem has been trying to find help for 3.1 scripting with the changes that have been made to it for this version. I am working through a tutorial that used 2.1.4 and have been having no end of trouble working in 3.1 trying to figure out what’s been changed and what hasn’t in the code, and spinning in the mud, going from one error to the next to the next - and then back around again where I started!

Strange, if you close the editor, the game process it spawned should have closed as well…

Zylann | 2019-03-29 14:05

I would think so. I have not found a single incident anywhere of anyone having this issue and it continues to this day. I don’t know whether it has anything to do with the project or it’s the editor itself having become corrupted. In any case, I have no idea how to remove the project from the game engine so I could replace the editor with a fresh copy, and then import the project.

I have tried to move a project from one computer to another and destroyed it in the process and had to rebuild it from scratch to the other computer. If I had this stuff down, it would be a matter of minutes to just build a new instance, but it does take time for me, still learning the basics.

Thanks for your response.

Euergetes | 2019-03-29 18:30

I just found something else here:

I went to create a new project but it won’t let me because the engine.cfg file exists in the root directory. If I attempt to remove this file, as noted above, it creates an error trying to open the project. As it stands, this file must be where it is to be able to open the project albeit in the round-about way.

Inorderto determine where this file is supposed to be located, I looked in the directory system for in my 3.1.0 build for its presence, and it does not exist anywhere. This build opens normally.

I am now wondering if this is what’s causing the issues I am having opening the editor, and if so, how can I fix this? As you can see, the engine.cfg contents contain the settings for the one project I have on there.

Euergetes | 2019-03-29 19:25

I’m having the same issue. I restructured my whole directory in windows explorer & it was fine…now I started adding particle systems & the project explorer window opens pretty regularly when pressing play.

WhoDidThis?? | 2020-12-06 22:52