Why doesn't my Android One-Click Deploy work in Godot 3.0 (beta1)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By HarryCourt
:warning: Old Version Published before Godot 3 was released.

So, I’ve finally got a mini game to work in Godot 3.0, beta 1, but when I decide to use One Click Deploy, it doesn’t work at all… It finishes the “Exporting for Android”, shortly after, so does the “Running on Samsung SM-T350”, yet, to no avail.

I have USB Debugger enabled on my Android Device (SM-T350), Which is version 6.0.1, and I have got my JDK, ADB and my debug.keystore.

Using Windows 8

run godot tool in cmd and see what error says.

volzhs | 2017-12-01 22:53

How would I do this?

HarryCourt | 2017-12-01 23:06

run cmd as following instruction below.
How to Open Command Prompt (Windows 11, 10, 8, 7, etc.)

go to directory which contains godot.exe
run godot.exe

volzhs | 2017-12-02 00:06

I’ve run it succesfully in the cmd, here’s the pastebin: C:\Users\Harry Court\Desktop\Godot 3.0>FOUND versionCodeFOUND versionNameFOU - Pastebin.com

HarryCourt | 2017-12-02 00:22

:bust_in_silhouette: Reply From: volzhs

you got this error.
you need to set proper Debug keystore at Editor Settings > Export > Android.


you can use your own keystore / user / pass for debug.

I’ve done this, yet to no avial. Here is what my paths look like: Screenshot - ad2fb5d024d4f500bda56b509a9e80a5 - Gyazo

HarryCourt | 2017-12-02 02:30