Why don't I have a 3D viewer?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By tfm

My engine is only showing 2D options. The very top of the window has buttons for “2D” and “Script”. It doesn’t have the “3D” like I see in example videos. Also, the scene only has options to Create Root Node: 2D Scene, User Interface, and Other Node. The “3D Scene” is missing. I can’t find any settings that would be causing this.

I installed version 4.0 last week and just installed 4.0.1 today but there was no difference.

:bust_in_silhouette: Reply From: tfm

I just figured it out. Under Editor → Manage Editor Features…

I don’t understand why, but there was only a “2D Profile” listed. I had to configure the selected profile and check the box for 3D Editor, which was the first option.