Why I can't load my patches in my game?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By random1izard

I’ve done everything here, but still not work.

func _ready():

This script is already in my test-game.
※I’ve tryed by using “func _your_function” like the tutorial said but it’s not work so I change it to “func _ready”.

I exported this game to exe, and back to place a random image in main scene.
Test the game, all things are fine.
Then I export this new version game as “patch.pck”.
I place patch.pck in the folder where my test-game.exe in.
And it’s not work. The scene is still empty like the first version.
※Tryed custom user dir(AppData\Roaming\test-game), too, but still not work.

Did I do anything wrong?
I’ve scearch this question a hole day but seems nobody have this question.

:bust_in_silhouette: Reply From: chotto

You can’t access the .pck file from the res:// filesystem. You have to pass the full file path as it’s seen by the operating system. For example: “c:\mygame\mypack.pck”