Why i can't move further?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By rot18

Scrollbar limits my view in editor 2d and i can’t move further. I must zoom out, but i don’t see anything because everthing is too small. Why it’s limited? This is basic feature.

Why such critical bugs exist in stable releases? It’s serious engine or machine to milk money from patrons?

rot18 | 2018-05-04 10:52

:bust_in_silhouette: Reply From: con_tone

The workaround I’ve been using for this is just making a locked Control the size of the area I want to work in.

It works, but only for small areas. If my control is too far, I can’t move to it. The only option is zoom.

rot18 | 2018-05-04 10:39

Why -1? It works for me too…
Other thing. That’s true that godot should have that option.
Other thing. In your terms Blender is machine to milk money from patrons? Lol. That’s funny. Blender even don’t have Scroollbars in 3d view! xd

Kamil Lewan | 2018-05-05 11:23

I dont need stupid scrollbar. I want to move camera, and i can’t because stupid scrollbar limits my view.

rot18 | 2018-05-09 18:49

:bust_in_silhouette: Reply From: Rikhardur Bjarni Ein

I know this was asked 2 years ago and no idea if that option was there at the time.
but there is Editor Settings → General → Editors → 2d → Constrain Editor View
which locks the viewport so it doesn’t stray far from the nodes.

Unticking that option gives you free movement.

2 years later, and I’m wondering why this isn’t unconstrained by default. Would give a much better user experience imho, especially first impressions.

faylite | 2023-02-25 01:01