Why is my scene loading slowly? Problem with Make Unique? Godot 3D

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By whitesundreams

I have recently followed this tutorial to completion. https://www.youtube.com/watch?v=XMfiojwtuKo

It was great and taught me most of the basics of Godot as I am going to try to move from Unity to this. Towards the end of the tutorial I noticed that the load times of a 3D scene was very large. This is a big concern to me because I know lots of users use Godot for 2D and may not have this issue.

In the comments of the video it says that there is an issue with Make Unique which is causing it to load slowly. Is this the case? How do I “un” make unique? I’m familiar with Blender and am a bit confused on how making a material or mesh unique would be different than making a new material from the original. What does this option actually do? What is the correct workflow?

Are there any other ideas on why my tutorial project’s scene loads slow? Could it have something to do with the GridMap?

Att Attached is an image of the Project, but I can upload my project if needed.

How big is/are your *.tscn file(s)?
A possible reason for long loading times are big scene files which often result from using embedded resources (i.e. textures). And yes, this could be caused by making some resource unique. How big is your *.tscn file?

I would recommend just going the normal way. Which is saving meshes and textures in the projects file system and not in the scene. You can check this by moving the mouse pointer over some texture/mesh and see if the path is inside the scene *.tscn or in an own file.

You can move resources out of a scene just by saving (if it is not already present as file) the resource to a file. Just right click and select save. All equal resources then can simply be loaded from that file (again, right click).

Naturally, there are also reasons for making resources unique. And that is if some definitions are actually changed/different. In case of bigger resources it might be useful to go other ways like i.e. saving a node as a new scene and linking it to the current scene. You can then ovverride individually some settings in linked copies of the scene.

wombatstampede | 2020-02-03 07:29

It was the Make Unique issue with the Grid View :frowning:

whitesundreams | 2020-02-03 16:51

:bust_in_silhouette: Reply From: whitesundreams

Thanks for the comment wombatstampede. I couldn’t edit my question but I already solved it over on my reddit post.


Answer: Don’t use Make Unique, at least on Materials, but I will probably be avoiding Make Unique for now. I fixed the issue by going into my Scene of Blocks that I use for my Mesh Library, making new Meshes and Materials for each Block and then converting to a new Mesh Library. Then in my scene with the original Mesh Library, I updated that to the new one.