Why is the Oneshot node always active?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By CasperBoesen

When i activate the OneShot node it stays on untill i turn it off. I thought it would play the animation and return after it finishes?

I recorded a video of the problem:

Yeah, seems like it’s not working properly. You can start a Timer (check oneshot and set time of the animation) and uncheck activate when timeOut, until it’ll be fixed

MrReda | 2021-01-15 19:27

:bust_in_silhouette: Reply From: Paul Erpenstein

Could be different things that cause it. Try the following:

  1. Assign the animation node directly to the oneshot nodes “shot”. I.E. Remove the “is_attacking” transition node
  2. Click on the Oneshot node and look if the autorestart property is set, if so disable it
  3. Click on the Oneshot node and enable the ominous “sync” property → Watch out here tho, i dont know what it does. Its just always fixes my issues when i turn it on ^^
:bust_in_silhouette: Reply From: duong_huga_ma

Make sure your Animation in animation player is not looping.

Thank you!!!

Barquero_Team | 2023-04-18 09:34