Why my Godot 2.1.4 don't write in the output window?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By ferhand
:warning: Old Version Published before Godot 3 was released.

Just like that. I download Godot 2.1.4, 64 bits and don’t write the print() calls…


My OS is windows 8.1 Enterprise 64

:bust_in_silhouette: Reply From: alphaa

Well there could be a range of causes for this problem. What is your code?

I have the same issue on Windows 8.1.
The print does not output anything to the console.

In my case it’s the exact same files/code.
When I open with 2.1.3 it works.

cardoso | 2017-09-01 20:36

btw im on the same os using 2.1.3 just fine, never tried 2.1.4 and dont see a reason why i should

alphaa | 2017-09-01 22:29

Same problem, same OS (64).
I’m having no problems with 2.1.3 but 2.1.4 does not write any output or debugger/error messages at all.
It seems to be related to THIS ISSUE but neither checking windows firewall exceptions or debug_host ip, or changing debug_port & remote_port makes any difference.

Possibly off topic, but 2.1.4. also takes significantly longer to start (F5) projects, and made the virus program much more nervous.

stillinthe90s | 2017-09-13 13:16

Does not matter which code I write the version 2.1.4 of Godot don’t write in the Output console…but the exact code, or any, using the 2.1.3 function perfect…Why?

ferhand | 2017-09-26 21:53

:bust_in_silhouette: Reply From: cardoso

A new answer on the question “Debugger and output malfunction” worked for me!


settings (top right corner of godot) → editor settings → network → change port to

Well, it start to function well now but I haven’t touch that option so maybe that’s not the real problem…

ferhand | 2017-11-29 04:36