Windows export won't run unless assets are imported in the editor first

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By SF123

I’m working on a 3D first-person shooter game, and I’ve come to the point that I want to try it on different devices, so I exported it to Windows, put it on a different computer, and ran it. It opened and let me go through the 2D settings menu scenes and stuff, but when I tried to click play it didn’t work and in the debug console it said couldn’t load resource, “res://assets/bla” make sure you’ve opened it in the editor at least once or something like that.

This is an issue especially if I’m going to eventually publish it, so any ideas are welcome.

Thanks in advance!

Did you export only the select assets of the project, or all the assets?

Ertain | 2022-01-23 18:49

:bust_in_silhouette: Reply From: rossunger

I found this problem sometimes happens in the editor too when Ive used class_name… something about circular dependencies, or broken references. I’ve had to edit the project.godot file in a text editor to remove certain references and then it would work again.

Do you have any idea what I would need to do? Here’s my project.godot file:

; Engine configuration file.
; It’s best edited using the editor UI and not directly,
; since the parameters that go here are not all obvious.
; Format:
; [section] ; section goes between
; param=value ; assign values to parameters



config/description=“A First-Person Shooter.”






(I removed the Inputs from here because it was too long)





I don’t see any dependencies or references…

SF123 | 2022-01-28 19:17

I think I misunderstood your issue…

This only happens at runtime? after you’ve exported and are trying to play the game?

Does it work fine when you run in editor? Does it work fine on your computer, and only throw this error on the other machine? Did you copy all the files that got exported?

When you open the export menu…under the resources tab, is it set to export all resources?

What type of resource is “res://assets/bla”?

rossunger | 2022-01-28 19:27

The exported program runs fine on the computer it was exported on, it only does not run on any other computer. “res://assets/bla” are 3d assets like .obj files and .fbx files. Yes it’s set to export all resources.

SF123 | 2022-01-28 20:24

hmm. hard to diagnose. I haven’t had this experience with godot before.

Have you tried running the game as administrator? (you shouldn’t need to, but if that worked it’d be clearly a permissions issue)

Have you checked to see if Windows defender/firewall are doing something stupid?

If it doesn’t work on multiple other computers in might be something to do with the export templates. Did you compile them from source? or download them? if download, are you sure they’re for godot 3.4.2, and not a different version?

Do you wanna post a wetransfer link to your game and I’ll see if I can see anything?

rossunger | 2022-01-29 15:49