Write/Load data in VR

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Constannnnnt

I am developing a VR application on Quest using Godot, and I want to save and load some data during the runtime. I follow the tutorial and this guide. I don’t find the system throw any error, however, I either don’t find where my saved files are. Does anyone encounter similar problems or have an idea for this problem or where I can find my saved files? Any help will be appreciated!

BTW, I checked the internal storage of Quest on PC through USB and did not files I expected.

Did you enable the required file access permissions when exporting for Android?

Also try using a file manager app directly on the device.

Calinou | 2020-07-16 10:13

HI, Calinou, I enabled read/write external permission at the export setting. Besides, I also request permissions at the runtime time if permission is not granted:

some pseudo code here
var perm = OS.get_granted_permissions()
if perm does not have android read/write external permission:
OS.request_permission(read/write external storage)

I looked at these two issues #1 and #2. From the discussion, it seemed that user:// is a hidden directory for each app and we can’t find files under user:// with other file browsing app. Basically, I can do dir.open("user://") and list all content in this directory, and still I cannot find my saved folder and files through a file manager either on PC or Quest itself.

So, I tried to create a directory similar to #1 and #2 and wanted to save data there: dir.make_dir_recursive("/Android/data/com.godotengine.name/"), and this time it threw the error creating such folders.

Do you have any idea about my problems or any other approaches that I can find my saved data through a file manager? Appreciation in advance.

One interesting problem here: I definitely enabled read/write external storage (check at the android export), and I did see when compiling, there were several lines saying “adding permission READ/WRITE” etc. but when I tried to print what the granted permissions were by the OS, var perm = OS.get_granted_permissions(), it returned an empty array. Any idea to this problem?

Constannnnnt | 2020-07-16 18:23

I’m having the same issue. Was this solved? Would be very helpful to have the solution as an accepted answer below. Many thanks!

semiflex | 2021-06-09 15:00

:bust_in_silhouette: Reply From: Constannnnnt

please check the discussion for reference.