Wrong Material being used in run-time versus in-editor?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By KobaDesu

After importing my model(s) into a new 3D scene from Blender, the wrong material is being applied. I am unsure what happened, but upon looking into the .import folder, the image that was used seemed to have been changed by Godot after import. I hope the following screenshots provide better context.

As seen in this first image, the colours are correct in the 3D editor (Bright, vibrant).
An image showing the full Godot editor screen

In this second image, you can see what it actually looks like in run-time (I am running the scene via F6).
An image showing the game during run-time. Its colours are different than the first image.

In the final image, you can see the image(s) that were imported alongside the materials. The image that is causing the issue is the pallet_solids[…].s3tc.stex. I am unsure where it came from, but I do know that it was generated when I imported the materials into Godot, and it, for some reason, was the default image being used. After swapping the texture back to the original image (as seen in the right bar), the texture/image looks correct in the 3D editor (as seen in picture 1) but Godot still uses the wrong/corrupt(?) s3tc.stex instead (as seen in picture 2) during run-time.
An image which shows the editor screen, and the two textures that are causing issues,

I am unsure if the errors shown in the log in images 1 and 3 are relevant; They are appearing because of the level/scene that the geometry/materials are in.

I have also tried exporting as .dae (using the better dae exporter plugin), .obj, and .fbx. They all result in the same thing; the “corrupted” .s3tc.stex being generated and used.

Any help or fixes would be greatly appreciated. I can provide a copy of the project if it would help at all; It is a Katamari clone I am making as a birthday gift.

Thanks in advance!

:bust_in_silhouette: Reply From: Andrea

very likely the washed out colour in the game are caused by ambient light you used in the environment

I might be late here… It happened to me now, I think the problem is that you copied the file and changed its color in a different editor.

What solved the problem for me was, deleting the file, and then in the recycle bin, recover the file and reimport in godot