Android-Export doesn't work since Godot 4.2.2

Godot Version

4.2.2

Question

Since Godot 4.2.2 I get the error “A valid Java SDK path is required in Editor Settings” when exporting to Android.

Previously there were no problems.

I have also tried with the latest version of Java and SDK. It does not work anymore.

Have you added the valid java SDK path to your editor settings?
It should look something like this on Windows:

So my installation folder is different.
I am using Windows 10 and have installed the following so far:

  • android-studio-2023.2.1.24-windows.exe
  • jdk-22_windows-x64_bin.exe

As already mentioned, it also worked with the Godot 4.2.1 version.

After I saw your screenshot with “Eclipse Adoptium” I searched for it and ended up on the website “https://adoptium.net/de/download/”. Now I have also installed “OpenJDK21U-jdk_x64_windows_hotspot_21.0.3_9.msi”. It still does not work.

How to install this JDK “Eclipse Adoptium”?

I have now reinstalled the “OpenJDK21U-jdk_x64_windows_hotspot_21.0.3_9.msi” in Program Files and again created a “Debug Keystore” with this JDK. I used these parameters:

keytool -genkey -v -keystore debug.keystore -storepass android -alias androiddebugkey -keypass android -keyalg RSA -keysize 2048 -validity 10000 -dname “C=US, O=Android, CN=Android Debug”

Now I get even more error messages when exporting.


I have just noticed in your screenshot that there is also a “Java SDK Path” and not just an “Android SDK Path”. I have now also selected the “Eclipse Adoptium” folder in the “Java SDK Path”. That doesn’t work either.

Now it works after I reinstalled “Android Studio” :smiley:

which version of ‘build-tools’ you using, i am aslo using godot4.2.2 to export androd apk, but it show errow, i was download the recommened version in offical website witch is:" Android SDK Build-Tools version 33.0.2", but it not working.

I am traveling for a few days and therefore cannot check.

Install the latest Android Studio and Eclipse Adoptium: https://adoptium.net/de/download/

i was already download both software you mention above, just yesterday,it was all newest, can you show me the version of “Android SDK Build-Tools” in your’s andord studio like the screenshot of mine to help me refer to ?

When I’m home tomorrow, I’ll post screenshots.

please share with us Ur environment setup jdk, sdk , ndk, command line, version