Android Export For Google Play

Godot Version

Godot Engine v4.2.1.stable.official (c) 2007-present Juan Linietsky, Ariel Manzur & Godot Contributors.

Question

I’ve compiled my game as an app bundle (abb) but every time I import it on the play console for my first release, play consol tells me the file isn’t signed. However, I’ve set the parameters correctly, debug keystore and releas keystore, android sdk path. And so on and so forth, and since then I haven’t changed a thing, just rebooted the computer with an error:

editor/export/editor_export_platform.h:182 - Exporter: La construction du projet Android a échoué, vérifier la sortie pour l'erreur :
  
  WARNING:We recommend using a newer Android Gradle plugin to use compileSdk = 33
  
  This Android Gradle plugin (7.2.1) was tested up to compileSdk = 32
  
  This warning can be suppressed by adding
      android.suppressUnsupportedCompileSdk=33
  to this project's gradle.properties
  
  The build will continue, but you are strongly encouraged to update your project to
  use a newer Android Gradle Plugin that has been tested with compileSdk = 33
  > Task :preBuild UP-TO-DATE
  > Task :preDebugBuild UP-TO-DATE
  > Task :compileDebugRenderscript NO-SOURCE
  > Task :assetPacks:installTime:generateAssetPackManifest
  > Task :generateDebugResValues
  > Task :generateDebugResources
  > Task :createDebugCompatibleScreenManifests
  > Task :extractDeepLinksDebug
  > Task :processDebugAssetPackManifests
  
  > Task :processDebugMainManifest
  C:\Users\Piran\Documents\Godot\android\build\src\debug\AndroidManifest.xml:11:5-132 Warning:
  	uses-feature#android.hardware.vulkan.level was tagged at AndroidManifest.xml:11 to replace another declaration but no other declaration present
  C:\Users\Piran\Documents\Godot\android\build\src\debug\AndroidManifest.xml:12:5-140 Warning:
  	uses-feature#android.hardware.vulkan.version was tagged at AndroidManifest.xml:12 to replace another declaration but no other declaration present
  
  > Task :mergeDebugResources
  > Task :mapDebugSourceSetPaths
  > Task :processDebugManifest
  > Task :processApplicationManifestDebugForBundle
  > Task :mergeDebugShaders
  > Task :compileDebugShaders NO-SOURCE
  > Task :generateDebugAssets UP-TO-DATE
  > Task :mergeDebugAssets
  > Task :compileDebugAidl NO-SOURCE
  > Task :generateDebugBuildConfig
  > Task :checkDebugAarMetadata
  > Task :processDebugJavaRes NO-SOURCE
  > Task :javaPreCompileDebug
  > Task :checkDebugDuplicateClasses
  > Task :mergeDebugJniLibFolders
  > Task :processDebugManifestForPackage
  > Task :mergeLibDexDebug
  > Task :writeDebugAppMetadata
  > Task :parseDebugIntegrityConfig
  > Task :linkDebugManifestForAssetPacks
  > Task :bundleDebugResources
  > Task :processDebugResources
  
  > Task :desugarDebugFileDependencies
  WARNING:C:\Users\Piran\.gradle\caches\transforms-3\9a2d4eb6c6396b495fa445404429297b\transformed\jetified-godot-lib.template_debug\jars\classes.jar: D8: One or more classes has class file version >= 56 which is not officially supported.
  WARNING:C:\Users\Piran\.gradle\caches\transforms-3\9a2d4eb6c6396b495fa445404429297b\transformed\jetified-godot-lib.template_debug\jars\classes.jar: D8: One or more classes has class file version >= 56 which is not officially supported.
  
  > Task :mergeDebugNativeLibs
  > Task :compileDebugKotlin NO-SOURCE
  > Task :assetPackDebugPreBundleTask
  > Task :mergeExtDexDebug
  > Task :mergeDebugJavaResource
  > Task :compileDebugJavaWithJavac FAILED
  
  FAILURE: Build failed with an exception.
  
  * What went wrong:
  Execution failed for task ':compileDebugJavaWithJavac'.
  > Could not resolve all files for configuration ':androidJdkImage'.
     > Failed to transform core-for-system-modules.jar to match attributes {artifactType=_internal_android_jdk_image, org.gradle.libraryelements=jar, org.gradle.usage=java-runtime}.
        > Execution failed for JdkImageTransform: C:\Users\Piran\AppData\Local\Android\Sdk\platforms\android-33\core-for-system-modules.jar.
           > Error while executing process C:\Program Files\Eclipse Adoptium\jdk-21.0.3.9-hotspot\bin\jlink.exe with arguments {--module-path C:\Users\Piran\.gradle\caches\transforms-3\6fdee9e5730a192d2b2ca9b8bc13c9e4\transformed\output\temp\jmod --add-modules java.base --output C:\Users\Piran\.gradle\caches\transforms-3\6fdee9e5730a192d2b2ca9b8bc13c9e4\transformed\output\jdkImage --disable-plugin system-modules}
  
  * Try:
  > Run with --stacktrace option to get the stack trace.
  > Run with --info or --debug option to get more log output.
  > Run with --scan to get full insights.
  
  * Get more help at https://help.gradle.org
  
  BUILD FAILED in 10s
  30 actionable tasks: 30 executed


This looks like a problem

And what’s the issue of this error? Do you know?

So if you read the warnings, it says your gradle doesn’t match your sdk.

1 Like

How to change it, I reinstalled the gradle but it still doesn’t work for the sdk I use the one from android studio but how to retrograde it?

You could upgrade Godot to the latest. They have updated the dependency for Gradle. That combined with OpenJDK 17 (later won’t work) works for me.

2 Likes

I no longer get the error even after rebooting the computer, but I’m back to my original problem, google app console tells me that my app bundle (.aab) is not signed.

I believe you still sign your .aab with a local key, google will manage another key that is unique to your app if it’s managed and will use that to sign it, but you’re still required to sign the aab on export. At least that’s been my experience so far.

Here are the relevant docs from Android’s developer site:

Shoot, I misremembered what I did with my upload key when I set up the upload to the play store a while back. You are right.

1 Like

but i already have a debug keystore and a relaes keystore, i also let google play manage the signature. But it’s always telling me that it hasn’t signed, to sign the application on export, it’s with the keystore?

Double check that under package settings, you have Signed checked to true

The other thing I’d check is to make sure you’ve got the debug setting toggled off

If these are both set correctly then would you be able to upload your gradle build output? Is it the same error you’re getting from the beginning of the post? Or something different?

1 Like

I just unchecked the “export withe debug” box and now I get another error when importing to google play console:

Your Android App Bundle has been signed with the wrong key. Make sure your app bundle is signed with the correct key and try again. The app bundle you imported should normally be signed with the certificate associated with the fingerprint
SHA1: FB:******************
However, the certificate used is associated with the fingerprint
SHA1: E5:******************

Are you using the same keystore file when you first uploaded to google play?

Even if you’re just uploading a “test” version of the app you don’t release to any track, I believe that it will still save the certificate that the app was signed with.

If you did generate a new keystore or change the specific keystore that you’re signing with, your private signing key might have been saved in google play, so if it changed you can request a reset:

That way your new signing key would be the one that google expects.

If you DIDN’T generate a new keystore, I’m not entirely sure what could be the issue :frowning:

1 Like

Thanks! that was it

1 Like