AudioStreamPlayer doesn't emit a signal "finished()".

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By AndrewD

A .ogg file is loaded in AudioStreamPlayer and the signal “finished()” is not emitt. However, if I download the .wav format, the signal is emitted.
I use the .ogg format precisely because it is lighter than the .wav format.

How to make the signal “finished()” emitted in .ogg format?
Or maybe there is a way to make the .wav format weigh significantly less?

:bust_in_silhouette: Reply From: supper_raptor

You have to disable loop in .ogg files. To do this -

1.)select .ogg file :

2.) go to import tab and uncheck loop and press Reimport :

Now you will get finished() signal

Thanks a bunch. This confused me too.

cybereality | 2021-04-29 22:56