Blender Import Weirdness (Additional dots) / Pixelart

Godot Version

Godot Engine v4.2.1.stable.arch_linux

Question

Hey everyone,
I am currently stuck on an issue so I thought I’d just ask.

I am creating some walls for a 3D pixel art type game in blender and I also added texture onto the walls.
I have already figured out removing the filtering (setting it to nearest) to get rid of the blurriness of the images but there is still something not quite right with how they look.

Here are some screenshots to visualize my issue (had to cramp them into one image as new users are not allowed to attach more). On top is how it looks in blender.
On the bottom there is the view from Godot (right is a closeup of the issue)

As visible there are a lot of additional dots that should not be there, so I am guessing there is an additional option for the import I am missing. (The part in the middle should be 90% of the same color - with some lines inbetween)

The view from the images you see are from the pure .blend files but I also tries exporting as colada & glf but no luck.

Does anyone maybe know what artifacts I am running into here and can point me into the direction to fix it?

I am still relatively new to blender and godot in 3D so I am sorry if the solution is obvious and I am just missing it.

Thanks for your time!

I’ve encountered the same when doing pixel art textures. What you see is texture compression. It works well with larger textures, but not generally on pixel art.

You can set the compression to Lossless in the import settings.

1 Like

Perfect thanks.
I did that for the actual images and now it works.

Thanks for the quick answer :slight_smile:

1 Like