Bright shadows?

Godot Version

v4.3.beta.custom_build [be56cab58]


I have written a little scene, just placing a few low-poly assets into a world environment. When I run this locally on my Mac or on my Pixel 7 phone (both with the “Mobile” renderer), I get a light ground, with dark shadows, as expected.
When I am running the same scene in the browser I get a dark floor with “shadows” that happen to be considerably lighter than the floor.

See this screenshot, both the archway and the tower should throw a dark shadow.

Any pointers how this could be possible?

Consider switching to the Compatibility rendering method in the project settings (including for the mobile override), as the Mobile rendering method has known issues on Android due to Vulkan driver bugs.

Sorry if my description was misleading. The mobile render on Mac and phone works well. The issue as depicted in the screenshot is on the compatibility renderer on web.