Cannot run scenes in any version of Godot 4 (Linux)

Godot Version

4.1.2
4.2.2
4.3 Beta 2

Question

Trying to run existing projects or start new projects, when I hit run (F5), the editor UI changes to show that the scene or project has started, but either nothing opens or I just get a black window. I have tried this with 4.1, 4.2, and the 4.3 beta. 3.5.3 works flawlessly, and I’ve even used it to export a working project. I get the same problem with an existing project and a new bare-bones project (just a 2d scene with a single ColorRect).

Running MX Linux Libretto (based on Debian 12) with the KDE desktop and Liquorix kernel:
Linux … 6.6.11-1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix 6.6-15.1~bookworm (2024-01-11) x86_64 GNU/Linux

I have tried both Wayland and X11, as I had come across someone mentioning issues with Wayland, and using both init and systemd. Same behaviour in all cases.

It’s really frustrating as I cannot work on any projects in Godot 4. I’m wondering if maybe there’s a config file somewhere that I can delete or reset, or some other issue that might be causing this? Possibly a permissions issue? I’m not sure what else to try.

Update: if I install the unofficial Godot 4.2.2 Flatpak, it works, so I think this must be due to some corrupt config file or similar. Any suggestions on what to fix or delete?