Can't open projects with Godot 4.x on M1 Pro Mac

Godot Version



I’m new here coming from the Unity side of the pond.

I’m having a weird issue. I can’t open any projects with Godot 4.2.1 (or any of the other 4.xx I’ve tried).
I can get to the screen where I can create projects, but when I try to run or edit a project it gets to the Godot logo screen and then stalls there. I’ve tried installing from the Godot website, GitHub, brew via terminal and can’t get any of them to work.

I can run 3.5.3 just fine but if possible I would like to start learning Godot with the newest version.

My machine is a MacBook Pro with an M1 Pro running macOS Sonoma 14.2.1.

Many thanks in advance!

Can you try deleting .godot folder in the project and try again?

PS: Make a copy just in case. :))

That doesn’t seem to work either.
But thank you!
Also tried deleting the cache and the contents of the Godot folder In application support, but so far no dice.

1 Like

I think it might be related to this open issue:


I was also encountering this issue and the comments here helped me find this workaround:

Download/update xcode via xcode-select --install if not already installed.
Open xcode and let it download additional software if prompted.
Clear any caches e.g. .godot/.
Create a new Godot project to verify it works with a fresh project.
Re-import your existing project that previously wouldn't open.

no problems on MacMini M1, OS 14.2.1, I also think ‘xcode-select’

v4.2.1.stable.official [b09f793f5]

start via terminal, debug mode + project
....../ -d --path /Users/alex/Develop/Godot/Projects/ActionRPG

1 Like

Thank you!
I had totally forgotten to update Xcode since the last minor OS update. That did the trick.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.