Can't run the project inside editor

Godot Version

Godot Engine v4.2.1.stable.official.b09f793f5


The run button inside the editor is not working, it loads for a second but won’t run anything. I can run the project in the launcher and it works fine but not the editor.

  1. running in the launcher.
  2. running in the editor.
  3. there is no output after running in editor.

Have you double checked you set a main .tscn scene file in Project > Project Settings > General > Application > Run > Main Scene ?

yup, main scene is fine. still not working. but thank you.

Did you try restarting the engine / your computer?

Can you share the project as a zip file? From the screenshots it seems like a small project without a lot of content yet. So being able to inspect it would help us narrowing down the issue.

Also what system are you running this on?

seems like restarting the pc did the job. thank you.
edit: it broke again and won’t work. idk why

here is my system info:
Intel Core i5-9400F CPU 2.90GHz
16.0 GB RAM
GeForce GTX 1660s
OS Windows 11 Pro

so idk why when I restarted my pc and ran a test project (simple scene and sprite2d showing the logo) it worked, but after I re-made my project it stopped working again. same with the test project, it no longer works.

my own project is nothing big just following a step-by-step YouTube tutorial:

you can download my project here:

or you can download the full project from the YouTube link, either way I can run projects from the project manager but not from the editor.

The print statements are working here, but the project you supplied contains a huge amount of extra resources that isn’t used for running the sample. Try to narrow the problem down by creating a minimal project (a project with just a Node2D with a script and a print statement in the _ready() function). You can also start the IDE from the command line version and see if there are any error shown there.

Okay so I have managed to find the problem, but I have to say it’s very bizarre.
I use a Hotspot shield VPN on my pc all the time, so I tested it a couple of times, disconnecting and connecting my VPN is the cause of this problem and it works fine when I’m disconnected.

1 Like

That makes sense, since the game and the editor communicate via networking. That’s how the internal debugger and the output panel receive their data.

You may be able to adjust your VPN settings to still allow this, and may also need to tinker a bit with the remote host/port editor settings so that it can find the game.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.