'canvas_items' mode causes visual artifacts

Godot Version

4.2.1.stable

Question

Vertical lines appear often when I move. How can I solve it?

I’m using the ‘canvas_items’ stretch mode, because I want to crisply rotate pixel art sprites like in this video: https://www.youtube.com/watch?v=pxXVqFqyRqI)

I’ve tried:

  • Enabling and disabling v-sync
  • Changing the scale and resolution of the game

I don’t know what to do.
:frowning:


I had a similar problem and I suspect that it might be related to window borders and this issue. I got rid off the lines by switching to Exclusive Fullscreen window mode.

1 Like

Thanks for your response!
Sadly the lines still appear even in Exclusive Fullscreen mode…

1 Like

the level is made with TileMap? try disabled the texture padding

1 Like

It wasn’t the texture padding, but looking for it I found my answer!

On the Rendering tab of the TileSet, enable “UV Clipping”.

Thank you for making me look!

1 Like