CharacterBody2D jittering in full screen mode

Godot Version



I’m making a 2D platformer and when I test the game in the regular non-fullscreen mode it’s fine (for the most part) but when I put the game to fullscreen mode the character is jittering pretty heavily (video below for reference). I’m using an M1 MacBook Pro and I’ve read that there is a Mac bug for fullscreen, but the thing is that the character controller I’m using for this game is copied from the Brackeys Godot 4 Tutorial and when I run that game in fullscreen mode I have 0 jittering issues. All the settings are identical to the template of the game so I have no idea what I’m doing wrong.

Is the project configured to use the integer stretch scale mode in the Project Settings?

Also, what framerate are you getting in fullscreen? If you are getting dropped frames due to the GPU not keeping up, then jittering will become visible by definition. Physics interpolation can help with this somewhat, but it’s not part of core until (you can use smoothing-addon for now).

Smoothing the camera may cause some visual odds in my experience.

Have you tried to set your camera process callback from idle to physics?


1 Like

Setting it to physics seems to have fixed it! Thank you!

It is very weird though that in the Brackeys tutorial it is set to Idle and gives me no issues, but this solved it for this game thank you.

It is using fractional, but I have the same issue with integer stretch scale mode. The FPS is about 110 in fullscreen and 120 when not in fullscreen.

If Im not wrong the issue happens with high refresh rate monitors.

Mine, for instance, is 240Hz and low resolution sprites look fuzzy in my case with idle camera.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.