Contents not resizing properly when changing screen size

Godot Version

4.2.2

Question

I have this issue, where I set a different screen size, the contents don’t scale properly. I have searched for solutions like changing some stretching properties in the Project Settings or similar, but no result.
Down below is one image of the correctly sized contents at a resolution of 1152x648 and the second at 1920x1080 not sized correctly.


Please share the relevant project settings (like stretch_mode you’re using), what your scene tree looks like, and if you changed any container sizing flags anywhere. There is no way anybody will be able to fix this for you based on two screenshots.

Alternatively, upload your project somewhere so we can take a look.

Yea, sorry my fault
I did solve the problem of the clock (The time saying “08:00”) being uncentered:


But I do still have the “issue” of the Labels not conforming to the size of the screen. And not only the Labels, but the rectangles surrounding the numbers as well.
Do you think I should still send my project files, or is this enough information for now?

Help… :pleading_face::pleading_face:

Yes, please.

Here’s the link to the project
It’s very messy, since I’m just testing a lot of things.
What I do think I could improve, is the communication system between the different windows. If you have any ideas for improvements, please tell me

Damn, always forgetting to press reply, instead of just sending stuff…

You want to use the “canvas items” stretch mode with a “keep” aspect. Set this in both the ProjectSettings (since this is what will get applied to the default window, e.g. when running GameTimer.tscn directly via F6), and in the settings for the Window node in GameWindow.tscn. For the latter, you also have to set the content_scale_size property to the size of its content (your GameTimer.tscn) – that is (1152, 648).

(post deleted by author)

Got it!

What solved it for me, was just inserting content_scale_size in script to what I needed. Probably isn’t the best solution for me, but it did solve my issue.

Thanks!!!