Cube grid shadows problem

Godot Version

Godot 4.2


Hi i’m trying to creating procedural terrain and need to get rid of the shadows/highlight in edges of the cubes. If i use only albeto color with no textures works but i cant find the setting to apply with textures.

Hi can you look at the scene with the “Display unshaded” debug view and the “Normal Buffer” debug view? (These can be found under the perspective button in the top left corner of the 3D Viewport.)

If the problem still occurs with the unshaded mode, it is likely a problem with the texture or the uv’s.

If the mesh clearly isn’t flat in the normal view, it is an issue in the mesh generator code, where it gets shaded as round instead of flat.
(Round normals left, flat normals right. Screenshot from kenny 3D platformer CC0)

The cube was imported from blender with smooth shading enabled. Solved, thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.