Debug window only opens in Fullscreen

Godot Version

Godot 4.2

Question

I am new to Godot, and I am working on my first 2d platformer game. I currently have 3 scenes, one titled “main,” one called “world” and one called “Player.” I was going to include screenshots, but it won’t let me put more than one as a new user.

in my settings I changed it at one point to be fullscreen upon opening, but now I’d like to change it back. However, despite my settings saying that it should open “windowed” it still opens in fullscreen.

Any suggestions on how I can fix this?

Another detail which may be relevant is that it seems like it begins to open as “windowed” but then goes fullscreen within a couple frames.

I could not reproduce it (on my MacMini M1), you could debug via gdscript

func _ready():
	print('win-mode:' , DisplayServer.window_get_mode())
  • WINDOW_MODE_WINDOWED = 0
  • WINDOW_MODE_FULLSCREEN = 3

I could not change it in the _ready function, but I could via a timer with a 1 second delay

DisplayServer.window_set_mode(DisplayServer.WINDOW_MODE_WINDOWED)

Perhaps check editor settings? There are separate settings for running the debug game there too.

yes maybe, I don’t know these settings yet, these are mine (default)

Search your codebase for window_set_mode and make sure you didn’t forget you made it go fullscreen in code.

Thanks! I thought it was something silly like that lol

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.