"Edit Filters" in AnimationTree nodes not working as expected

Godot Version

v4.2.1.stable.mono.official [b09f793f5]

Question

I’m not sure if this is a bug or something I’m just misunderstanding?

I’m trying to use the approach described here to animate a placeholder character model looking around: GitHub - smix8/Godot_3D_Character_LookAt_Guide: Guide how to implement 3D character LookAt behaviour inside the Godot Game Engine 3.2+

My AnimationTree’s blend tree looks like this:

image

I have only one bone selected in the “Edit Filters” popup for the Blend2 node:

But the filter doesn’t seem to apply. Moving the Blend2 node’s slider from 0-1 changes between the idle animation and the head-turned pose completely, for the whole skeleton, not just for the head bone.

How can I fix this, and blend only for certain bones?

Oh wow. It took going to the trouble to post it to finally notice the “Enable Filtering” checkbox in the popup. After checking “Enable Filtering”, it works as expected. I guess I will leave this here for anyone else who has the same problem.