Export build seems to use old data/assets

Godot Version

4.2.2

Question

I recently changed fonts for my project and deleted the old one. When I make an exported build and try to run it the console says the old font is being imported and there is no reference to it (the second part makes sense, I deleted it after all), so the games doesn’t open. However, when I run the game inside the engine, everything works fine, and displays the new font. I tried looking for imports to the old font in the project, but there are none. It seems like the exported version is using old information to make the build.

Here is an unlisted video showing what I mean.

UPDATE: I tried cloning my project again and it seemed to work. Maybe some weird cache going on when exporting? Is there a way to clear it?

Did you check the project settings?
There is at least one place where a font can still hide.
GUI/Them/CustomFont

The field was clear. Tried exporting, same thing.

Then I put the new font in it. Tried exporting, but still, same thing happens.