GLTF imports differ greatly from Blender (uv and normals)

Godot Version

v4.2.1.stable.official [b09f793f5]

Question

Tried to import some new Models I created.

For some reason two of my models have inverted normals (they look perfectly fine within blender and the windows native glb previewer).
I tried to enabled the “force disable compression” but that didn’t help either.

Model in Blender (good normals):

Model in Godot (corrupted normals):
image

The UV-maps for the models also seem corrupted but I am not sure if it is related.

Model in Blender (corrupted UV):
image

Model in Godot (corrupted UV):
image

The export options I used in blender:

bpy.ops.export_scene.gltf(
	filepath=fp,
	use_selection=True,
	export_apply=True,
	export_format='GLB',
	export_materials='NONE',
	export_image_format='NONE',
	export_cameras=False,
	export_lights=False,
)

Does it look the same when exporting through Blender’s File/Export menu? Can you upload the .blend file somewhere we can download it from?

Found the issues with the normals after inspecting them more closely in blender. The whole model was created by modifiers which got confused by the mirroring of parts. After applying them (before inside the export script) and regenerating the normals, it plays nicely now.

The UV was related but required me to unwrap the UV anew and redo everything. Not sure what the issue was specifically though. But applying/removing the mirror operator fixed it as well.

But as a big takeaway so far: watch what the “modifiers” are doing to normals :upside_down_face: