(Godot 3) The script editor disappeared?

3.5.3 Godot Version

So I just got started today, and I’m working with a tutorial online to learn how to use Godot with C#. The first time I was following along the tutorial, everything was working fine, but I messed up the code and wasn’t sure where I went wrong, so I got out and got back in. But, since I did that, and every attempt afterward, the script editor has disappeared. I cannot interact with any of the scripts I created unless I’m using different software, and even then there’s no way for me to import/export the scripts into Godot.

I’ve tried opening the scripts individually, opening/closing Godot, drag+dropping the scripts into that area, trying to go to FIle>Open>Sprite.cs, nothing has worked.

I’ve been looking for answers, but I haven’t found any. What do I do?

What are your editor settings for external editors? Maybe try resetting those

I’m not sure? I turned it on, but nothing seems to have changed. How do I reset the settings?

Hmm, that looks ok. So double-clicking a file in the editor does not work for opening it?

No. I’ve also tried going up to “open file” and opening it through there. It’s like the app thinks the editor is open, even though there’s no interface.

Does this happen in a new project too if you create a script there?

Yes, it does.

That’s weird. You could try deleting your editor settings. They should be in a file in %APPDATA%\Godot\ on windows. Be sure to make a backup of anything you delete first, just to be sure you can restore it if anything goes wrong.

Other than that I’m out of ideas.

There is a clear error in your output window. It could be your script has an issue and Godot isn’t handling it well.