Godot 4.2 .net constantly freezing

Godot Version

Godot 4.2 .net


I have Godot 4.2 .net and everything freezes for minutes every few minutes.
It’s unusable in this condition.
It takes minutes before even the project selection comes up.
Then in the editor, it’s freeze after freeze very frustrating.

plz help or direct me to a solution xx

AMD Ryzen 7 7800x3D
Windows 11

Do you have a semi-large tileset in your scene by chance? My editor would experience extreme slowdowns like this when I had a tileset with many tiles.

For now I just removed the tileset, don’t need it to test basic game mechanics. Hope the problem is fixed by the time I need to re-add a tileset. I’m pretty sure the editor worked fine in 4.1.2; problems began after upgrading to 4.2.

To test, open only scenes that don’t have tilesets and see if situation improves. A shot in the dark, but thought I’d share…


Start a console (press Win key and then “cmd”) and then start Godot’s using Godot_v4.2-stable_mono_win64_console.exe in the console. Now all errors are printed to the console and you can see if Godot spams any suspicious errors before or during the freezes.

If nothing else helps, create an issue: Issues · godotengine/godot · GitHub

1 Like

Dizzy, any idea what this command could look like on a Mac?

Unfortunately I don’t have a Mac. But check this command line tutorial: Command line tutorial — Godot Engine (stable) documentation in English

I guess using --verbose command line argument could be comparable to using console version in Windows.

1 Like

I have the same problem in regard to tilesets. My scene has a very large map and a bunch of smaller maps. Messing around in that scene always crash eventually. I didn’t have that problem before 4.2. Other scenes without tilesets work fine.

EDIT: I ran the editor from cmd and when it freezes, I get this:

ERROR: Condition "p_elem->_root != this" is true.
   at: remove (./core/templates/self_list.h:80)

I looked on github at that line but honestly idk what that means so I just downgraded back to 4.1 for now

1 Like

Thanks for this info!

You‘re right. Tileset causes the problem. To be precise, patterns (图案 in Chinese ver.) cause it in godot 4.2. There are serval situations:

  1. Too many patterns saved
  2. A pattern is too large
  3. The area painted by pattern in scene is too large

My png picture’s size is 1488x688 and it doesn’t cause the problem unless I use patterns.
So I recommend avoiding using patterns in tilemap unless they fix the bug.
By the way, i didn’t test other versons so I dont know if it apperences in other versons