Godot 4 black screen in editor cant access anything tried everything (PC)

Godot Version

4.2.1

Question

I wanted to try Godot 4 but when I open any project for the first time it just shows a black screen, I cant access anything in the editor but when i click on the top left it shows the boxes with the options, except there are no options and when i right click in the middle my mouse disappears indicating that the editor is partially there only that its pitch black and all the things dont work.

I tried everything updating drivers, restarting, switching displays, editing files and updating windows nothing works at all

1 Like

try lower version, godot 4.0 or 4.1

Nope, tried around 5 or 6 previous versions from 4.1.3 to 4.0 and all of them either crashed or had the black screen glitch

which windows version you using?

Windows 11

i have the same windows 11 and it works perfectly fine there for godot 4.2.1 stable
did you tried the console editor? what it said there when it shows black screened editor?

WARNING: Blend file import is enabled in the project settings, but no Blender path is configured in the editor settings.
at: _editor_init (modules/gltf/register_types.cpp:63)

Have you tried to switch to the Compatibility mode? Open the file project.godot in a text editor, and add renderer/rendering_method=“gl_compatibility” to the section [rendering].

Yes I tried that it didnt work, also there is no rendering section here is what is it the text editor:
; Engine configuration file.
; It’s best edited using the editor UI and not directly,
; since the parameters that go here are not all obvious.
;
; Format:
; [section] ; section goes between
; param=value ; assign values to parameters

config_version=5

[application]

config/name=“zad”
config/features=PackedStringArray(“4.2”, “Forward Plus”)
config/icon=“res://icon.svg”

If there is no rendering section, add it to the end of the file:

[rendering]

renderer/rendering_method="gl_compatibility"
2 Likes

Tysm it works now

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.