Godot 4 compatibility mode for linux

Godot Version

Godot 4.3 dev5 linux.x86_64


Hello. I used to use godot 4 on Windows 10, but some time ago I had switched to Linux, to be more precise, to Ubuntu Budgie 23.10 x86_64. When I switched, I immediately downloaded the same version of Godot I had been using for the last months. However, I can normally open the project manager, but when I try to open a project, it crash after load the editor, even in compatibility mode and even in a new project. When I researched, I only found people who cannot use Godot because their computers do not support that. Why could my computer run Godot 4 normally on Windows 10 but not on Ubuntu?
If it’s just a driver problem or something like this, I’m already going to apologize and delete this topic. I am new to the Linux world and I’m a little confused.

note: If I try to open it through ubuntu terminal, it returns the “FATAL: Index p_index = 1 is out of bounds (size() = 0).” error.
note2: my godot4 version is v4.2.1 stable official. I had tried to open it with godot 4.3 beta, but the same thing happens.

Since now, thanks for every help!

did you download the AppImage version?

are you using X11/Xorg or Wayland? you can see it in the login screen, on a button on the page where you can chsnge your password.

Gosot runs on the older and insecure X11, and it needs a compatibility layer for yhe newer Wayland, called Xwayland, I don’t know whether Ubuntu comes with Xwayland

unrelated to Godot but to Linux

if you came to Linux because it’s free and open source software, I’m sorry but you were fooled: Ubuntu uses a strong, proprietary software underlying its system, making its app store a mess, and trying (and failing to) monopolize the Linux packaging industry, with their package manager snap. it also prohibits their child distros and users to use packages which are not snap, including blocking Flatpaks, the competing and open source, package manager.

if you like Budgie, I recommend the Fedora Budgie Spin, it uses the most default desktop it can, leaving the system clean.

Hello. Before everything, thanks for your answer.
I didn’t download the AppImage version. Should I do it? If so, can I download it on main godot4 download page?

I’m actually using X11 windowing system. How do I use the compatibility layer for Xwayland? If I can, of course. (I’m going to research about compatibility layers)

about linux

I didn’t come to Linux because it’s free or open source. I actually came to “linux world” because I was interested and my programming professor recommended it for programmers. As I had a prior interest, I simply booted Lubuntu as my first distro.

I had been researching more about Fedora and Arch and how Ubuntu isnt a good choose for Linux users. With your comment, i’m even more sure and confident of Fedora switching! Thanks for the recommendation by the way!

as far as I can see, Godot isn’t officially supported as Flatpak or Snap, but officially as an AppImage (or maybe as a binary? I’m not sure):

I got a similar problem to you, but it indeed was duet to compatibility mode, because of flatpaks limiting GPU acceleration, which is changable with the Flatseal app

about Linux

I would also advise against Arch and derivatives, as they are complex, from time to time updates break the system, the real package system they use isn’t verified and may be insecure.
Other distros I use to recommend for years are Linux Mint, PopOS, and ZorinOS, though I fear their future as they are forks of Ubuntu (without snaps but they allow you to choose if you want to use them)

If you’re using X11, you don’t need xwayland or any compatibility layer. Just download the Linux version.

I actually had downloaded by this link. Is my problem more relate to my system or the way i downloaded godot?

I had downloaded the Linux Version

users from Windows and Ubuntu reported it happening since 4.0, which, comprehensively, didn’t happen to everyone, and even seem to be “sometimes happening” to those who were affected.

its seems you will need help from people who handle Godot itself

I had seen this github issue, and was fearing it was a bigger problem. Well, I’m going to change to Fedora Budgie. Thanks for recommendation!
And I’m not going to mark this help topic as resolved/solved, just in case anyone else can find an possible solution

1 Like