Godot crashes the moment it opens

Godot 4.2 stable

Whenever I try to run the program, it closes a split second after the window shows up, and when I try to use Godot 3 it doesn’t even try to open the window at all. I can’t find any other people with this sort of problem, and I don’t really have any information to give. plain and simple, Godot crashes the moment it opens, no error message, no nothing. It happens with every version of Godot i try, and even with games other people have made on Godot. I’m running windows 11, and I have a decent computer, so I don’t see what could cause this problem other than some sort of incompatibility, but my computer works just fine with other Vulkan programs, so I don’t know.

Try running with the console, you should be able to identify the error just before it crashes.

image

1 Like

So when I would run that before it would basically do the same thing, but after i restarted my computer, Godot worked again for a moment, but then it just closed again?? so I restarted again and now it’s working, but I presume it’s probably gonna crash again at some point.

Hello i am having the same problem, but i am on Windows 10.
After running the editor with the console, i see no error. Another thing that i have noticed is that the gd scripts that i was editing were not saved at all.

When you run your programs from Godot, make sure to put attention to any Errors in the Debugger. Even though Godot might seem to handle the errors gracefully, they might cause instabilities under the hood. After all, the Godot IDE is written in Godot.

Ok i can check that, but i think is not related to that because i also tried to delete all the Godot data in AppData, in that way it should not know with project to load or where is located, so i think it’s not related to the project, but to something else

Try the latest 4.2.1 and the dev 4.3 just to be sure.