Godot does not launch?

Godot Version



godot does not launch???
I downloaded the basic version of godot (without C#)
I run the exe: Godot_v4.2.1-stable_win64.exe
I have the interface to create a new project,
I name my project, go find the path or save it
the path is D:\virgile\my creations\video games creation\GODOT\projects\project1
I do “create and open”
a black window appears for 4 seconds then disappears
and that’s all !!!..

I have a
nvidia geforce GTX 970M
with open GL 4.5
spec of my card: GeForce GTX 970M | Specifications | GeForce

Thanks for your help !

Can you try to run the .NET version of Godot?
You can still use normal gdscript with it without any C#.
And at least on my build, the .NET version editor seems to run slightly better (for 3d).

The .NET version of Godot has a “Godot_v4.2.1-stable_mono_win64_console.exe” executable too.
Try to run that, and check the console for errors if you are still getting that black screen.
It might help identify your problem.

as a beginner I didn’t yet know the usefulness of the console… thank you very much!!! :slight_smile:
in fact she detected an error here it is in an image:

is this a problem with vulkan? where can i download it, do you think my graphics card supports vulkan?

This feels like this issue.


vkCreateComputePipelines failed with error -1000012000 · Issue #70772 · godotengine/godot · GitHub

It seems it is a driver incompatibility error with vulkan.

There are a couple of things you can do

  • You can use the Compatibility renderer for now. This problem is specific of the Foward+ renderer.

  • Some people reported that updating the Nvidia drivers solved this issue.

  • You can still make it work by running the program with “–rendering-driver opengl3” argument to force it to use opengl.

yes great thank you, I saw this workaround solution:
“I found a workaround using command line arguments when starting Godot:–rendering-driver opengl3”

where and how to write this line of code? :
--rendering-driver opengl3


You need to execute the program with the command line interface.

If you are on windows. Use the cmd.exe form the start menu.
And call it with the godot .exe path + that command args.

“F:\Programs\Godot 4.2.1\Godot_v4.2.1-stable_mono_win64.exe” –rendering-driver opengl3

You can also create a shortcut for the Godot exe
Right-click the shortcut → properties → in the shortcut tab
There is a Target field.
You can put at the end, after the .exe: –rendering-driver opengl3

That way, when you execute the shortcut it will already have that argument so you don’t need to type the whole command every time.

Here’s a guide on how to use shortcut arguments for windows (https://www.digitalcitizen.life/shortcut-arguments-parameters-windows/)


great thank you for this more than valuable help!
if I understood correctly this serves me to say to godot
start with opengl3 and not vulcan as it does by default, is that right?
Is this the same thing that happens if I start a project in “Compatibility” mode?

Yes, this is the same as creating a project in the Compatibility renderer.

The reason this exist is that you can’t change the renderer of a project that is already created without opening it.
So you can’t change the renderer to Compatibility if you crash while opening the project.

That option forces godot to always use Compatibility renderer if I’m not mistaken.

1 Like

great thank you very much I learned a lot of things, I think it’s good the project opens!
how can I close the topic?
Many thanks again!!! :slight_smile:

1 Like

You already marked it as solved, so it will close automatically in a month

1 Like

Just in case if someone like me don’t know how to use cmd
You can use a simple shortcut which is MUCH much easier for example here is mine:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.