Godot Editor Crash (Vulkan issue?)

Godot Version

4.2.1 .NET build

Computer

ASUS ROG Ally Z1 Extreme

Question

The Godot editor crashes with no error code when attempting to run any project. I was able to previously run without an issue, but following a crash when closing the editor (which appears to have been cause by OneDrive) I cannot launch any project from Godot. I have browsed similar topics on the forums and taken the following actions:

  1. Run Godot in OpenGL mode/Windows 8 compatibility mode.

Godot will open projects using either of these modes, but they suffer a significant performance hit, making testing my projects take way too long. In addition, using OpenGL allows me to run the editor, but launching a test crashes, also with no errors.

  1. Update AMD drivers.

No updates available. In addition, despite running perfectly until about a week ago, I have not gotten any further driver updates.

  1. Check %AppData%

I’ve looked in the AppData folder in my user account, but am not sure if I’m even in the right place, since directories referenced in previous help topics are not at the paths suggested. Unable to do anything remotely useful.

  1. Reinstall Godot

Does literally nothing.

I’m completely at a loss at this point. Uninstalling the AMD drivers actually allows me to start my projects until I restart and reinstall the drivers, although it runs really laggy. Frankly, it’s the closest to “functional” I’ve gotten the thing since this issue started.

Have you tried a stable version of the engine without C# as an .exe?
Maybe try compiling the engine yourself?

I have exactly the same problem but with the regular version of godot, without C#, and also with Rog Ally Z1 Extreme. I am 99% sure it’s a driver stuff.

This started literally ~2 weeks ago, before that everything worked fine

Found the solution!
Microsoft somehow install app on my ALLY (and probably all ALLY’s), you need to delete this program “Compability Packet OpenGL, OpenCL…” (Settings → Installed Apps)

After unistall - everything now works fine for me (Forward+, Mobile, Compatible)

1 Like

Confirmed! Was just running updates to see if that would fix it so I can confirm it wasn’t working this afternoon, but uninstalling that app makes Godot work!